Some older versions of browsers and Operating Systems have limited functionality. If users are using a product that is out of date and no longer supported, they may encounter issues while using the NCCER Registry website.

Please be aware that some browsers have not been tested yet, as the system was just released. Users are advised to use a supported browser to ensure everything will work correctly and to avoid errors while navigating the Registry.

Additional recommendations

  • Use Firefox, Chrome, or Internet Explorer Version 11 when working within the Registry
  • Pop-up blockers should be set to allow pop-up messages
  • Please make sure your browser has Cookies Enabled
  • Please make sure your browser has Javascript Enabled
  • Clear Cache and Cookies
  • Change the Compatibility View settings within the browser
  • There may be limited support for mobile devices

Last Updated August 2016